Notes

Chris Ross

December 20th, 1995

CaliachMRP - Normal upgrade to V2

Upgrading to CaliachMRP V2.50 from V2.28 or earlier

1. Read this document through before doing anything. Then go through it item by item until you have successfully upgraded to V2.50. Read the notes that come with the upgrade:

Macintosh Windows™ Notes
V2.50 ReadMe Bugs READ50_B.TXT Bugs fixed since V2.50 since V2.2800 was released
V2.50 ReadMe Wishes READ50_W.TXT Feature Additions since V2.50 since V2.2800 was released
CalMRP Contacts Notes CONTNOTE.WRI Contact Marketing Database custom feature notes
CalMRP Custom Notes CUSTNOTE.WRI Custom Features Library notes

2. Install Omnis 7 V3 Development from the Omnis 7 Workgroup Edition CD Rom. Use the instructions that come with the CD Rom to do this. Remember to make a note of the serial numbers printed inside the CD Rom case cover. Note that serial numbers prefixes are as follows:

CMDI = Macintosh 680x0 workstation Development Omnis 7 V3

CMRI 10M = * Macintosh 680x0 workstation 10 concurrent user Runtime Omnis 7 V3

CPDI = Macintosh PowerPC workstation Development Omnis 7 V3

CPRI 10M = Macintosh PowerPC workstation 10 concurrent user Runtime Omnis 7 V3

CWDI = Windows 3.1/Windows for Workgroups workstation Development Omnis 7V3

CWR1 10M = *Windows 3.1/Windows for Workgroups workstation 10 concurrent user Runtime Omnis 7 V3

* Most users will be unfamiliar with multi-concurrent-user runtimes. They are simply runtimes that can be used by up to 10 users at the same time. You only have to install the Omnis 7 runtime once with this serial number. It can then be copied to all workstations or left on the server for users to launch from there (though this causes greater network traffic). Up to 10 concurrent workstations can then operate with a CaliachMRP data file and Omnis doesn't care what workstation it is. An eleventh user trying to attach to the data file will be prevented with the message "Too many workstations in ". Note that if you have both PowerPC and 680x0 runtimes you can theoretically have 22 users attached simultaneously.

Windows 95 is supported now with PATCH95.DLL installed in the EXTERNAL directory within the directory OMNIS7.EXE resides.

3. All CaliachMRP program and lookup data files have been changed. However you should backup the following files which you may need to refer back to with Omnis 7 V1 in order for you to reproduce site-specific changes on your new V2.50:

Macintosh Windows™ Notes
CALIACH.INF CALIACH.INF Your license file held in the "Caliach Extras" folder [EXTRAS directory]. A new V2.50 version of your license will be included with your disks on a Licence Disk.
CAL_USER.DF1 CAL_USER.DF1 Your terminal preferences file held in the "Caliach Extras" folder [EXTRAS directory]. You may have different variants of this file on different machines. You can, but it is not recommended, convert this file to Omnis 7 V3 data format. However it is better to load the newly supplied file with your site-specific entries using User Preferences in V2.50 of CaliachMRP.
CalMRP Options CALOPTON.APP Contains any customized reports or other features you may have developed. See later instructions.
Any other files you have created Any other files you have created You need to ensure that any archive files automatically placed in the "Caliach Extras" folder [EXTRAS directory] are saved outside the "CaliachMRP" folder [CALIACH directory]. You may have Ad Hoc Report designs and other documents that need to be retained.
Your Data File Your Data File.DF1 Your data file should be backed up at regular intervals during the upgrade process
CAL_STR.DF1
CAL_HELP,DF1
CAL_TOP.DF1
CAL_STR.DF1
CAL_HELP,DF1
CAL_TOP.DF1
These files can be saved if you have made any custom changes to them, e.g. 4000 string options, menu texts, help, etc.They will be updated by Omnis 7 V3 to V3 format, however they will not perform as well under these circumstances. We recommend that you use the new files supplied with CaliachMRP V2.50 and reproduce any changes made before.

It is a good idea to hold a floppy disk containing the first three items above as a Site Master.

If you have enough disk space a good approach is to rename the CaliachMRP folder [CALIACH directory] and keep it until you are confident that all upgrading has been successfully completed and the system has been running well for a few days.

4. If you are upgrading from a version other then V2.28xx, refer to the notes for upgrading earlier versions.

5. Follow the installation instructions enclosed with the disks to load CaliachMRP V2.50 onto the Development workstation (containing the Development version of Omnis 7).

6. All files have changed from previous versions, however functionality is identical to V2.2803:

Macintosh Windows™ Notes
V2.28 - V2.50 Upgrade UP28-25.APP Omnis 7 V1 Application needed to prepare your datafile for upgrade to V2.50.
CaliachMRP* CALMRP.LBR* No new files have been added, but Record Sequence Number fields have been added to files that did not have them already.
CalMRP Administrator CALADMIN.LBR File structure changes as CaliachMRP.
CalMRP Transfer CALTRANS.LBR File structure changes as CaliachMRP.
CalMRP Options CALOPTON.LBR File structure changes as CaliachMRP.
CalMRP Contacts Library CALCONLB,LBR File structure changes as CaliachMRP. This application does not fall under standard Caliach Telephone Support and Software Maintenance.
CalMRP Custom Library CALCUSLB.LBR File structure changes as CaliachMRP. This application does not fall under standard Caliach Telephone Support and Software Maintenance.
CalMRP Data Fix CALDAFIX.LBR File structure changes as CaliachMRP. It has improved performance. The ability to re-program itself to accommodate site-specific file formats has been added.
CAL_STR.DF1** CAL_STR.DF1** Should replace the older one in the Caliach Extras folder [EXTRAS] directory.
CAL_HELP.DF1** CAL_HELP.DF1** Should replace the older one in the Caliach Extras folder [EXTRAS] directory.
CAL_TOP.DF1** CAL_TOP.DF1** Should replace the older one in the Caliach Extras folder [EXTRAS] directory.
CAL_USER.DF1** CAL_USER.DF1** Should replace the older one in the Caliach Extras folder [EXTRAS] directory.

* copy these onto all user's workstations.

** copy these or your own updated versions to all user's workstations.

7. It is STRONGLY RECOMMENDED that you take this update opportunity to Re-index your entire data file. If you have a damaged index, that you haven't noticed, running the upgrade without re-indexing will destroy your data file. To re-index, make a note of the size of the data file, then, enter in Single User Mode using your old version of CaliachMRP [CALMRP.APP], install the Utilities menu, operate the Check Data File function, select all files, select the Re-index radio button and check the Check Free Blocks checkbox and finally, Start. It will take a good long time, so let it run overnight or over a weekend. If you interrupt, the data file will be destroyed. One characteristic of a failure to re-index correctly, is that the data file size grows substantially. If this happens you must restore the backup data file and will need to create a new data file using the CalMRP Data Fix [CALDAFIX.APP] application. Do not use the CalMRP Data Fix (V2.50) [CALDAFIX.LBR] library for this.

8. To upgrade your data file you need to go through a two stage process. This will take a long time - many hours if you have a large data file. The first stage is to re-organize the data using Omnis 7 V1 and the "V2.28 - V2.50 Upgrade" [UP28-25.APP] application to bring the fields into line with the V2.50 data structure (see 9 below). Secondly, you open the datafile using CaliachMRP V2.50 [CALMRP.LBR]. An automatic process of upgrade will then follow (see 10 below).

9. Backup your Data File, then launch Omnis 7 V1. Open the "V2.28 - V2.50 Upgrade" [UP28-25.APP] application in Single User Mode and select your data file.

You will be asked if you have Re-organized the data. Answer No. Confirm your intention to re-organize and let it run without interruption. When complete:

Select Change Data File from the Upgrade V2.28-V2.50 menu. Select your datafile again. When the same "Have you re-organized?" message appears, answer Yes. If all is well, you will receive a message telling you that you are ready for upgrade to V2.50. Quit [Exit] back to the Finder [Program Manager].

10. Launch CaliachMRP V2.50 [CALMRP.LBR]. If you receive a question "Do you want to load the Development Shell", answer No. (If you want to prevent this question being asked, move the O7DSHELL.LBR file out of the Omnis Extensions folder [EXTERNAL directory] in the Omnis 7 folder [OMNIS7 directory].

Select the data file prepared in 9 above. You will be asked if you really want to convert the data file. Answer Yes. This may take some time.

Enter your User ID and Password. Confirm with an Ok.

The upgrade will then proceed automatically. Do not interrupt this process. It goes through three stages: Checking for re-organization, Data dictionary update and Data Conversion. The final process will take a very long time with the counter jumping up erratically. At the end, you will get a message that the data has been upgraded. Note that the datafile will expand somewhat.

11. Launch Omnis 7 V3 and Open a copy of your old CalMRP Options [CALOPTON.APP]. You will be asked whether you want to upgrade the application to V3 format. Answer Yes. Having done this you can handle the upgrade in the same way a s normal.

12. Update the new CalMRP Options [CALOPTON.LBR] and CaliachMRP [CALMRP.LBR] using the "Transferring Custom Features" section attached.

13. Copy CaliachMRP [CALMRP.LBR] and other appropriate files to all your users.

14. We recommend that you •Re-set Part Process Quantities• from the "Reset Data Files" in the "System Manager" menu. This will correct for any data errors caused by some past bugs.

Transferring Custom Features

1. This process is only necessary if you are using any Custom Features or Reports in CaliachMRP. These features will be saved in your pre-update version of CalMRP Options [CALOPTON.LBR].

2. Your old CalMRP Options file should have been renamed or placed in alternative folder (directory) to the new version (Windows™ users must apply the suffix .LBR]. For these notes the old version is referred to as OLD and we will call the new CalMRP Options as supplied by Caliach, NEW.

3. Launch your development copy of Omnis 7.

4. Open (use "Open" from the "File" menu) OLD in Single User Mode.

5. Select "Examine Application File" from the "Utilities" menu.

6. Use the mouse and Command [Ctrl] key to select all your custom formats. If you have custom procedures in M_CUSTOM1, include this format.

7. Click on the •Copy• button.

8. Click on the 'Prompt for new name' radio button, Select NEW in the file selection dialog and click on •OK•.

9. For each format you will be asked to confirm, or change, its name. With M_CUSTOM1, you should change the name to TEMP. If the name is already in use in NEW you will be warned with a message saying "That name is already in use, Delete the existing format?". You should answer No and change the name.

10. You have now transferred your custom features into the upgraded CalMRP Options.

11. Open (use "Open" from the "File" menu) NEW in Single User Mode.

12. Check the Caliach update notes to see if anything has changed that may effect your custom formats, and if so amend them.

13. If you have custom procedures, they will now be in a menu format called TEMP.

13.a From the "Design" menu select "Formats". (Make sure you are using Long Menus - if available and you are in Short Menus, select "Long Menus" from the "File" menu).

13.b If the list window presented is not headed Menus, select Menus in the list at the bottom left of the screen. You will be presented with a list of menu formats including TEMP and M_CUSTOM1. Ensure that the Modify multiple formats checkbox at the bottom of the screen is checked.

13.c Select M_CUSTOM1 and click on the •Modify• button.

13.d Repeat steps a and b.

13.e Select TEMP and click on the •Modify• button.

13.f From the list on the left (the procedure list) select the first procedure containing any custom commands.

13.g With the mouse, select all your custom commands (do not select any comments at the top which were originated by Caliach).

13.h Select "Copy" from the "Edit" menu.

13.i Select "Cycle Format" from the "Design menu so that you are viewing the M_CUSTOM1 menu format.

13.j Select the same Procedure as in TEMP from the procedure list.

13.k Click on the first empty command line on the right.

13.l Select "Paste" from the "Edit " menu.

13.m You have now transferred you custom procedure into the new M_CUSTOM1 format. Repeat this process for all your custom procedures.13.n Save to disk by closing all design windows.

14. NEW has now been updated with your custom features and procedures.

15. Select "Examine Application File" from the "Utilities" menu.

16. Use the mouse and Command [Ctrl] key to select all your custom formats. If you have custom procedures in M_CUSTOM1, include this format.

17. Click on the •Copy• button.

18. Click on the 'Prompt for new name' radio button, Select the new CaliachMRP [CALMRP.LBR] application in the file selection dialog and click on •OK•.

19. For each format you will be asked to confirm, or change, its name. If the name is already in use in CaliachMRP you will be warned with a message saying "That name is already in use, Delete the existing format?". With M_CUSTOM1, you should answer Yes, otherwise answer No, and change the name.

20. You have now transferred your custom features into the upgraded CaliachMRP. Run the new CaliachMRP and test that your custom features still work with the new version. Backup the new, upgraded CalMRP Options [CALOPTON.LBR] (that we have been calling NEW in these notes).